log in | register | forums
Show:
Go:
Forums
Username:

Password:

User accounts
Register new account
Forgot password
Forum stats
List of members
Search the forums

Advanced search
Recent discussions
- Aemulor (Gen:16)
- !OBrowse reviewed (News:1)
- DDE reaches release 28 and above (News:)
- Elesar quicks dispels stormy clouds (News:2)
- RISC OS London Show 2017 - Notes from the talks (News:2)
- RISC OS London Show 2017 (News:)
- RISC OS London Show 2017 - Pictures (News:)
- October News (News:2)
- Retrospective thoughts on 12 months of Titanium ownership (News:4)
- RISC OS London Show 2017 (News:1)
Latest postings RSS Feeds
RSS 2.0 | 1.0 | 0.9
Atom 0.3
Misc RDF | CDF
Site Search
 
Article archives
Acorn Arcade forums: General: A3000 no DESKTOP
 
  A3000 no DESKTOP
  Revo (17:14 31/1/2017)
  geraldholdsworth (18:25 31/1/2017)
    Revo (18:31 31/1/2017)
  Michael Foot (01:18 2/2/2017)
    CJE (11:18 2/2/2017)
      Revo (13:46 2/2/2017)
 
Steve Over Message #124005, posted by Revo at 17:14, 31/1/2017
Member
Posts: 3
Hi, I've removed a leaked battery and cleaned up a A3000 that I purchased off ebay. I've got it working as far as the Supervisor mode but I can't load DESKTOP.
I've tried DEL and R at switch on, I get the red border, but then it goes to Supervisor.
When I type DESKTOP, it does nothing but if I RMReinit some of the unplugged modules I then get different errors when I type DESKTOP.
I've attached a 1.2V battery that is from a working A3000 and also I've tested the ROMs in the working A3000.
It seems to me (I'm a long way off of being an expert) that the CMOS isn't keeping it's commands.
  ^[ Log in to reply ]
 
Gerald Holdsworth Message #124006, posted by geraldholdsworth at 18:25, 31/1/2017, in reply to message #124005
Member
Posts: 12
Have you checked continuity on all the connections around the battery?
Mine had a hair line crack across a track leading to the CMOS chip which prevented it from retaining the settings (couldn't see the break, but there was no continuity). It is also known for a leaking battery to damage the RTC chip.
  ^[ Log in to reply ]
 
Steve Over Message #124007, posted by Revo at 18:31, 31/1/2017, in reply to message #124006
Member
Posts: 3
Thanks for the reply. I've found a diagram of the CMOS circuit, I'll check the connection.
  ^[ Log in to reply ]
 
Michael Foot Message #124008, posted by Michael Foot at 01:18, 2/2/2017, in reply to message #124005
AA refugee
Posts: 24
You will need to keep the Del or R key held down until you see something on the screen. Also check the floppy drive light to see if an error code is generated.
  ^[ Log in to reply ]
 
Chris Evans Message #124010, posted by CJE at 11:18, 2/2/2017, in reply to message #124008
CJE Micros chap
Posts: 198
The red border is only ever shown if it is doing a CMOS reset.

If it is a dead RTC/CMOS chip you can hire a plug in replacement from us!
See: http://www.cjemicros.co.uk/blog/?p=110

In addition to continuity you need to check for shorts to earth and other lines, we have found that quite common.

[Edited by CJE at 11:20, 2/2/2017]
  ^[ Log in to reply ]
 
Steve Over Message #124011, posted by Revo at 13:46, 2/2/2017, in reply to message #124010
Member
Posts: 3
Thanks, I've found the Supervisor mode is intermittent and I haven't been able to get into it for awhile. I will try a bit more cleaning.
  ^[ Log in to reply ]
 

Acorn Arcade forums: General: A3000 no DESKTOP